Installation

Prerequisites

Palace requires CPython version 3.6 or above for runtime and pip for installation.

Via PyPI

Palace can be installed from PyPI:

pip install palace

Wheel distributions are built exclusively for GNU/Linux on amd64. If you want to help packaging for other platforms, please reach out on our mailing list.

From source

Aside from the build dependencies listed in pyproject.toml, one will additionally need compatible Python headers, alure, a C++14 compiler, CMake 2.6+ (and probably git for fetching the source). Palace can then be compiled and installed by running:

git clone https://git.sr.ht/~cnx/palace
pip install palace/